Incident Timeline 6 updates

Resolved Jul 22, 2026 · 02:49 PM UTC

Between 11:54 - 14:07 UTC, we experienced checkout errors for stores using Stripe Payment Gateway. A fix was implemented at 14:07 UTC which resolved the issue. The monitoring period for this issue has ended and no further impact has been observed.

Monitoring Jul 22, 2026 · 02:13 PM UTC

This issue has been resolved and is being monitored.

Identified Jul 22, 2026 · 01:23 PM UTC

We've identified the problem impacting our third-party payment provider and we're working on a solution.

Investigating Jul 22, 2026 · 01:13 PM UTC

We are actively working with our third-party payment provider and we will update you as we resolve the checkout errors.

Investigating Jul 22, 2026 · 12:56 PM UTC

We can confirm that merchants with Stripe Payment Gateway enabled may experienc one of the following: * Multiple payment options enabled, Checkouts will not surface the credit card form. * Merchants with only credit cards enabled, Checkouts will continue to surface and continue to see processing and other errors.

Investigating Jul 22, 2026 · 12:40 PM UTC

Some Checkouts with Stripe Paymentmay experience checkout errors with payment failure or other error message.

← Back to all incidents