Resolved Minor

Interruption in service on some stores

Some stores are currently inaccessible. We are investigating and will keep you updated.

0 affected component
Started
Mar 22, 2020 • 08:30 AM UTC
Resolved
Mar 22, 2020 • 08:30 AM UTC
Affected components

Incident Timeline

1 public update
Mar 31, 2026 • 11:36 PM UTC
Resolved
Some stores are currently inaccessible. We are investigating and will keep you updated.