Resolved Minor

Customer notification emails not being sent for some stores

Some stores are temporarily not sending email notifications to customers. We are investigating and will keep you updated.

0 affected component
Started
Dec 19, 2019 • 04:24 PM UTC
Resolved
Dec 19, 2019 • 05:08 PM UTC
Affected components

Incident Timeline

3 public updates
Mar 31, 2026 • 11:35 PM UTC
Resolved
This incident has been resolved.
Mar 31, 2026 • 11:35 PM UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Mar 31, 2026 • 11:35 PM UTC
Investigating
Some stores are temporarily not sending email notifications to customers. We are investigating and will keep you updated.