Resolved Major

Admin and Storefronts experiencing intermittent downtime

We are currently investigating this issue.

3 affected components
Started
Nov 25, 2019 • 02:46 PM UTC
Resolved
Nov 25, 2019 • 04:34 PM UTC
Affected components
Admin, Checkout, Storefront

Incident Timeline

4 public updates
Mar 31, 2026 • 11:32 PM UTC
Resolved
This incident has been resolved.
Mar 31, 2026 • 11:32 PM UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Mar 31, 2026 • 11:32 PM UTC
Investigating
We are continuing to investigate this issue.
Mar 31, 2026 • 11:32 PM UTC
Investigating
We are currently investigating this issue.