Resolved
Major
Storefront, Admin and Checkout down for some stores
We are experiencing an interruption in service affecting Storefront, Checkout and Admin. We are investigating and will keep you updated.
3 affected components
Started
Oct 21, 2019 • 09:03 PM UTC
Resolved
Oct 21, 2019 • 09:27 PM UTC
Affected components
Admin, Checkout, Storefront
Incident Timeline
3 public updates
Mar 31, 2026 • 11:34 PM UTC
Resolved
This incident has been resolved.
Mar 31, 2026 • 11:34 PM UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Mar 31, 2026 • 11:34 PM UTC
Investigating
We are experiencing an interruption in service affecting Storefront, Checkout and Admin. We are investigating and will keep you updated.