Resolved
Minor
Shop Pay unavailable
Shop Pay is currently unavailable. We’re investigating and will keep you updated.
1 affected component
Started
Jun 24, 2025 • 06:57 PM UTC
Resolved
Jun 24, 2025 • 07:30 PM UTC
Affected components
Checkout
Incident Timeline
4 public updates
Mar 31, 2026 • 08:35 PM UTC
Resolved
This incident has been resolved.
Mar 31, 2026 • 08:35 PM UTC
Investigating
Shop Pay is unavailable at this time, we are continuing to investigate and will update here when more information becomes available.
Mar 31, 2026 • 08:35 PM UTC
Investigating
We are continuing to investigate, Shop Pay is unavailable at this time.
Mar 31, 2026 • 08:35 PM UTC
Investigating
Shop Pay is currently unavailable. We’re investigating and will keep you updated.