Incident Timeline 6 updates

Resolved Jul 17, 2026 · 04:57 AM UTC

Between 00:30 UTC and 03:33 UTC, we experienced an infrastructural issue that resulted in errors across Shopify storefronts and checkouts. A fix was implemented at 03:33 which resolved the issue. The monitoring period for this issue has ended and no further impact has been observed.

Monitoring Jul 17, 2026 · 04:45 AM UTC

This issue has been resolved and is being monitored.

Identified Jul 17, 2026 · 04:22 AM UTC

We've identified the problem and are seeing recovery from our mitigation efforts. We will continue to monitor and update.

Identified Jul 17, 2026 · 03:02 AM UTC

We've identified the problem impacting storefronts and checkouts, and we're working on a solution.

Investigating Jul 17, 2026 · 02:17 AM UTC

We're continuing to work on addressing the storefront and checkout issues, and will keep you updated.

Investigating Jul 17, 2026 · 02:02 AM UTC

Merchants and buyers may experience issues when trying to access Shopify storefronts, and attempting to check out. We are investigating and working to resolve these issues.

← Back to all incidents