Incident Timeline 3 updates

Resolved Jun 25, 2026 · 12:36 PM UTC

Between 11:13-11:35UTC , we experienced errors when accessing admin, checkout, storefront and POS. A fix was implemented which resolved the issue. The monitoring period for this issue has ended and no further impact has been observed.

Monitoring Jun 25, 2026 · 12:36 PM UTC

We have identified the issue affecting various aspects of the platform. Recovery is underway and we are continuing to monitor closely.

Investigating Jun 25, 2026 · 12:36 PM UTC

We have identified the issue affecting admin, checkout, storefront, and POS.

← Back to all incidents