Incident Timeline 8 updates

Resolved Jun 04, 2026 · 04:45 AM UTC

Between 13:06 UTC and 14:52 UTC, we experienced an infrastructural issue that resulted in errors across Shopify admin, Shopify POS, storefront, and checkout. This issue also impacted access to Shopify Support. A fix was implemented at 14:22 UTC which resolved the issue. The monitoring period for this issue has ended and no further impact has been observed.

Monitoring Jun 03, 2026 · 07:13 PM UTC

This issue has been resolved, and we are continuing to monitor. More updates will be shared as they become available.

Monitoring Jun 03, 2026 · 06:00 PM UTC

We continue to monitor the issue closely and will share updates as they become available.

Monitoring Jun 03, 2026 · 04:38 PM UTC

We are continuing to monitor the issue, and will share more information as soon as possible.

Monitoring Jun 03, 2026 · 03:31 PM UTC

This issue has been resolved and is being monitored.

Identified Jun 03, 2026 · 02:37 PM UTC

We've identified the problem and are seeing recovery from our mitigation efforts. We will continue to monitor and update.

Investigating Jun 03, 2026 · 01:45 PM UTC

We are investigating and will keep you updated.

Investigating Jun 03, 2026 · 01:27 PM UTC

Merchants may experience issues when trying to access the Shopify admin. Customers may experience issues with accessing storefronts and checkouts.

← Back to all incidents