Incident Timeline 4 updates

Resolved Sep 18, 2026 · 02:02 PM UTC

This incident has been resolved.

Monitoring Sep 18, 2026 · 01:53 PM UTC

A fix has been implemented and we are monitoring the results.

Identified Sep 18, 2026 · 01:48 PM UTC

The issue has been identified and a fix is being implemented.

Investigating Sep 18, 2026 · 01:40 PM UTC

Some customers may experience issues with the Shop App. Products are not loading. Some shops may not be available.

← Back to all incidents