Resolved Major

PayPal not processing payments

We are currently monitoring an issue where PayPal is experiencing an interruption in service preventing payments from being processed for some stores. We’re working on a solution PayPal and will keep you updated.

2 affected components
Started
Jan 25, 2020 • 02:48 PM UTC
Resolved
Jan 25, 2020 • 03:13 PM UTC
Affected components
Checkout, Point of Sale

Incident Timeline

2 public updates
Mar 31, 2026 • 11:35 PM UTC
Resolved
This incident has been resolved.
Mar 31, 2026 • 11:35 PM UTC
Monitoring
We are currently monitoring an issue where PayPal is experiencing an interruption in service preventing payments from being processed for some stores. We’re working on a solution PayPal and will keep you updated.