Resolved
Minor
Some merchants may experience delays or failures related to Shopify Flow and Webhooks
We are investigating the issues related to Shopify Flow Webhooks and will keep you updated.
3 affected components
Started
Apr 28, 2026 • 02:46 PM UTC
Resolved
Apr 28, 2026 • 09:21 PM UTC
Affected components
Admin, API & Mobile, Third party services
Incident Timeline
8 public updates
Apr 28, 2026 • 09:21 PM UTC
Resolved
Between 14:46 UTC - 21:20 UTC, we experienced an issue with the delay or failures of Shopify Flow and Webhooks. A fix was implemented at 20:33 UTC which resolved the issue. The monitoring period for this issue has ended and no further impact has been observed.
Apr 28, 2026 • 08:33 PM UTC
Monitoring
This issue has been resolved and is being monitored.
Apr 28, 2026 • 07:34 PM UTC
Investigating
We are still working on improvements in delay time and to resolve the issue.
Apr 28, 2026 • 06:30 PM UTC
Investigating
We are seeing improvements in delay times, and are continuing to monitor that.
Apr 28, 2026 • 05:14 PM UTC
Investigating
We are still working to resolve the issue.
Apr 28, 2026 • 04:29 PM UTC
Investigating
We are working to resolve the issue, and will continue to keep you updated.
Apr 28, 2026 • 03:03 PM UTC
Investigating
We are still investigating and will continue to keep you updated.
Apr 28, 2026 • 02:46 PM UTC
Investigating
We are investigating the issues related to Shopify Flow Webhooks and will keep you updated.