Resolved Major

Checkout completion delayed for some stores

We are experiencing an interruption in service preventing payments from being processed for some stores. Online store checkouts will remain in our queue and buyers will be notified once payments are complete. Checkouts from other sales channels, including Point of Sale (POS), may be unavailable during this time. We are investigating and will keep you updated.

8 affected components
Started
Jan 25, 2020 • 03:05 PM UTC
Resolved
Jan 25, 2020 • 03:16 PM UTC
Affected components
Admin, Checkout, Reports and Dashboards, Storefront, API & Mobile, Third party services, Support, Point of Sale

Incident Timeline

3 public updates
Mar 31, 2026 • 11:35 PM UTC
Resolved
This incident has been resolved.
Mar 31, 2026 • 11:35 PM UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Mar 31, 2026 • 11:35 PM UTC
Investigating
We are experiencing an interruption in service preventing payments from being processed for some stores. Online store checkouts will remain in our queue and buyers will be notified once payments are complete. Checkouts from other sales channels, including Point of Sale (POS), may be unavailable during this time. We are investigating and will keep you updated.