Resolved
Minor
Analytics, metrics, reports and Flow delayed
Analytics, metrics and reports are currently delayed for some stores. Flow automation may also be delayed. Search results for any new additions to stores are also delayed. We are investigating and will keep you updated.
1 affected component
Started
Nov 12, 2019 • 02:18 PM UTC
Resolved
Nov 12, 2019 • 05:10 PM UTC
Affected components
Reports and Dashboards
Incident Timeline
4 public updates
Apr 01, 2026 • 12:57 AM UTC
Resolved
This incident has been resolved.
Apr 01, 2026 • 12:57 AM UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Apr 01, 2026 • 12:57 AM UTC
Identified
The issue has been identified and a fix is being implemented.
Apr 01, 2026 • 12:57 AM UTC
Investigating
Analytics, metrics and reports are currently delayed for some stores. Flow automation may also be delayed. Search results for any new additions to stores are also delayed. We are investigating and will keep you updated.