Incident Timeline 5 updates

Resolved May 24, 2026 · 07:45 PM UTC

Between 17:43 UTC and 19:10 UTC, we experienced Shopify Flow workflow failures due to issues with Google cloud Platform. A fix was implemented at 19:10 UTC which resolved the issue. The monitoring period for this issue has ended and no further impact has been observed.

Monitoring May 24, 2026 · 07:16 PM UTC

This issue has been resolved and is being monitored.

Identified May 24, 2026 · 07:07 PM UTC

The issue has been identified and a fix is being implemented.

Investigating May 24, 2026 · 06:48 PM UTC

We are investigating and will keep you updated.

Investigating May 24, 2026 · 06:48 PM UTC

Shopfiy Flow may not be triggering properly for some stores.

← Back to all incidents