Incident Timeline 3 updates

Resolved Aug 27, 2026 · 06:51 PM UTC

The monitoring period for this issue has ended and no further impact has been observed.

Monitoring Aug 27, 2026 · 06:41 PM UTC

The issues with the Shopify Help Center have been resolved, and are being monitored.

Investigating Aug 27, 2026 · 06:31 PM UTC

Our live chat support may be unavailable on the Shopify Help Center due to a technical issue. We are investigating and will keep you updated.

← Back to all incidents