Resolved Minor

Merchants may experience errors when using Shopify POS embedded apps

Some Shopify POS embedded apps may not load as expected. Users may see blank pages when trying to load Shopify POS embedded apps. This issue is not expected to impact checkouts.

1 affected component
Started
Apr 06, 2026 • 02:48 PM UTC
Resolved
Apr 06, 2026 • 09:00 PM UTC
Affected components
Point of Sale

Incident Timeline

9 public updates
Apr 06, 2026 • 09:00 PM UTC
Resolved
The monitoring period for this issue has ended and no further impact has been observed.
Apr 06, 2026 • 08:16 PM UTC
Identified
We are working to resolve the identified POS embedded app issue and will provide an update in 4 hours, or sooner if more information becomes available.
Apr 06, 2026 • 07:19 PM UTC
Identified
We've identified the problem impacting POS embedded apps and we're working on a solution.
Apr 06, 2026 • 06:17 PM UTC
Identified
We've identified the problem impacting POS embedded apps and we're working on a solution.
Apr 06, 2026 • 05:17 PM UTC
Identified
We've identified the problem impacting POS embedded apps and we're working on a solution.
Apr 06, 2026 • 04:24 PM UTC
Identified
We've identified the problem impacting POS embedded apps and we're working on a solution.
Apr 06, 2026 • 03:56 PM UTC
Investigating
We are investigating and will keep you updated.
Apr 06, 2026 • 03:04 PM UTC
Investigating
We are investigating and will keep you updated.
Apr 06, 2026 • 02:48 PM UTC
Investigating
Some Shopify POS embedded apps may not load as expected. Users may see blank pages when trying to load Shopify POS embedded apps. This issue is not expected to impact checkouts.