Incident Timeline 5 updates

Resolved Jul 10, 2026 · 10:29 PM UTC

Between 14:30 - 17:20 UTC, some merchants and customers experienced issues accessing storefronts and admins. The monitoring period for this issue has ended and no further impact has been observed.

Monitoring Jul 10, 2026 · 05:54 PM UTC

We are continuing to monitor to ensure the health of the affected areas.

Monitoring Jul 10, 2026 · 05:19 PM UTC

These issues have been resolved and error rates are back down. We are continuing to monitor.

Identified Jul 10, 2026 · 04:47 PM UTC

We're continuing to work on addressing the admin and storefront issues, and will keep you updated.

Investigating Jul 10, 2026 · 04:24 PM UTC

Storefronts and admins may be showing elevated, intermittent errors currently. We are investigating and working to resolve these issues.

← Back to all incidents